안드로이드 마켓(Android Market)에서 앱이 검색이 되지 않거나 기기와 호환되지 않는 항목이라고 뜨는 경우는?

 
KBS Classic Now, 안드로이드, 아이폰에서 클래식음악과 FM라디오를 무료로 들을수 있는 어플
얼마전에 위 앱을 리뷰를 했는데, 클래식을 좋아하시는분이 검색을 해도 해당 앱이 나오지가 않는다고 하더군요.

이런식으로 다른 사람들은 잘 사용을 하고 있는데, 나는 아무리 검색을 해봐도 검색이 전혀 안뜨는 경우가 있습니다.


이 경우는 사용자의 문제라기보다는 개발쪽에서 문제가 있는것인데, 안드로이드 앱을 개발할때 최신버전으로 개발을 하게되면 이전 버전에서는 스마트폰의 마켓에서는 검색이 되지 않으며, apk 파일을 구해서 직접 설치를 한다고해도 돌아가지 않습니다.

안드로이드폰 프로요 업데이트(Froyo Update) - 2.2버전의 코드네임
오모시로님의 MIUI 한국어판 MOG 4.0.1 안드로이드 아이스크림 베타 버전 출시
HTC Desire HD에 안드로이드 아이스크림OS 4.0.1 오모시로님의 MIUI MOG 설치 사용기

안드로이드는 1.x부터 현재 아이스크림인 4.0버전까지 계속 업그레이드가 나오고 있는데, 간혹 개발사의 사정상 최신 기술이 적용된 2.3 버전으로 개발을 한다면 2.2버전이하의 스마트폰에서는 앱이 실행되지 않습니다.

해결책은 제조사의 홈페이지등을 찾아보아서 최신버전으로 업그레이드를 받으셔야 합니다.
물론 최근에 말썽이 되고 있는 갤럭시S처럼 더이상 지원을 하지 않는다면 방법은 거의 없습니다.

폰을 최신기종으로 바꾸시거나, 또는 사용자들이 만든 커스텀롬을 가지고, 루팅을 하셔야 합니다.(물론 이게 초보자에게는 쉬운일은 아닙니다...-_-;;)


안드로이드 마켓 홈페이지 - http://market.android.com/

그리고 스마트폰에서는 조회가 아예 안되지만, 위 사이트에 가시면 조회가 가능하고, 자신이 가지고 있는 여러 기종들과 해당 앱이 호환이 되는지를 알수 있습니다.

위의 사진을 보면 갤럭시탭 7인치용으로 나온 제품인데, 제가 사용하는 KT HTC DHD는 4.0으로 롬업을 해서 설치가 되지만, 테스트폰으로 쓰는 폰은 기기와 호환되지 않는 항목입니다라고 나옵니다.


삼성 갤럭시S 안드로이드 4.0(아이스크림샌드위치, ICS) 업그레이드 불가, 해결책은 없는 걸까?
갤럭시S가 풀린지 1년이 좀 넘었는데, 업그레이드가 되지 않는다고 하는데, 개발자들이 보통 2.1 버전기준으로 앱을 제작하기때문에 뭐 지금 당장은 큰  불편은 없을겁니다. 하지만 지금도 갤럭시S가 판매되고 있는데, 1-2년이 지나서 새로나오는 폰들이 상당부분 4.0을 탑재하고, 개발자들이 대거 4.0 버전으로 개발을 하게된다면, 최신앱을 사용할수 없는 경우가 발생을 할수도 있습니다.

암튼 이야기가 엉뚱한곳으로 흘렀는데, 마켓에서 앱이 검색되지 않는 경우에 자신의 OS를 업그레이드 하거나, 최신 폰으로 교체를 해야 한다는것만 알아두시면 좋을듯 합니다.